Multibanco Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID:INC0255497
Posted Mar 17, 2025 - 03:23 UTC

Investigating

We are investigating а potential issue with our provider SIBS (Multibanco) and apologize for the impact this might have on your business.

Further updates will follow.

MIM Paysafe
Posted Mar 17, 2025 - 03:20 UTC
This incident affected: Third Parties (Multibanco).