Service Disruption - Checkout V2

Incident Report for Paysafe

Resolved

This incident has been resolved.

Reference ID: INC0282664
Posted Oct 14, 2025 - 19:19 UTC

Investigating

We are investigating a potential issue with the service mentioned below and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0282664
Posted Oct 14, 2025 - 18:57 UTC
This incident affected: Processing and APIs (Checkout V2).