US Merchant Billing Statements Delay

Incident Report for Paysafe

Resolved

The incident has been resolved successfully.

Reference ID:INC0254610
Posted Mar 11, 2025 - 13:18 UTC

Investigating

This is to notify that there will be delays with the February Fiserv merchant billing statements. We apologize for any inconvenience this may cause and will follow up once the statements have been loaded.
As a reminder, your Clover merchants can access their merchant statements directly through their Clover dashboard for faster visibility. Thank you.

Reference ID:INC0254610
Posted Mar 04, 2025 - 13:48 UTC
This incident affected: Third Parties (Fiserv First Data).