Payment Processing Service Disruption

Incident Report for Paysafe

Resolved

This incident has been resolved.
Posted Aug 30, 2026 - 06:51 UTC

Investigating

Our partner Fiserv are investigating a potential issue with their services and we apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0319412
Posted Aug 30, 2026 - 06:45 UTC
This incident affected: Third Parties (Fiserv First Data).