Partner Maintenance - Niubiz

Scheduled for Feb 10, 07:30 - 09:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 06, 2026 - 19:50 UTC

Scheduled

Please be advised that our partner Niubiz will be performing planned maintenance on their services.
Services may experience a 5 min downtime between 07:30 UTC and 07:35 UTC.

Reference ID:CHG0315643
Posted Feb 06, 2026 - 19:47 UTC
This scheduled maintenance affects: PagoEfectivo (Niubiz) and Third Parties (Niubiz).