Service Disruption - paysafecard payment

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.

We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while we were remediating the situation.
If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
MIM Paysafe

Reference ID: INC0257762
Posted Apr 15, 2025 - 23:15 UTC

Monitoring

A solution has been implemented and activity on the impacted services is being monitored.
We will keep you informed on progress.

MIM Paysafe

Reference ID: INC0257762
Posted Apr 15, 2025 - 21:59 UTC

Identified

The root cause of this incident has been identified and our technical teams are working on implementing a solution.
We will keep you informed on the progress.

MIM Paysafe

Reference ID: INC0257762
Posted Apr 15, 2025 - 19:35 UTC

Update

Please note that upon further investigation, the impact is confirmed to be limited to myPaysafecard IBAN feature. Teams continue to investigate the issue. Thank you for your understanding.
Posted Apr 15, 2025 - 18:21 UTC

Investigating

We are investigating issues with our paysafecard payment API and apologize for the impact this might have on your business.
Our technical teams are working on a solution and will keep you informed on progress.

If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
MIM Paysafe

Reference ID: INC0257762
Posted Apr 15, 2025 - 16:57 UTC
This incident affected: Paysafecard (merchant) (PSC Payment, PSC Payment myPaysafe, PSC Payout & Refund, Paysafecash Payment).