Payment fee records missing

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner RS2 was remediating the situation.
MIM Paysafe

Reference ID: INC0262275
Posted May 23, 2025 - 14:08 UTC

Investigating

Be aware that we are experiencing an issue with our payment processor where payment fee records are missing.

We are working with them to rectify the issue.

ETA of the resolution provided by RS2 is May 07 2025

Reference ID: INC0262275
Posted Apr 29, 2025 - 16:13 UTC
This incident affected: Third Parties (Paysafe Acquiring RS2 - Invoices).