Service Disruption - Salesforce

Incident Report for Paysafe

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 15:30 UTC

Monitoring

A partial fix has been implemented, while the teams are working on a permanent solution, intermittent timeouts are expected.
Posted Sep 16, 2026 - 15:17 UTC

Update

Our provider Salesforce has identified the root cause and is working on implementing a solution.
MIM Paysafe

Reference ID:INC0321795
Posted Sep 16, 2026 - 11:42 UTC

Identified

We are currently experiencing an issue with a third-party email service, which may prevent messages sent to our support teams from being delivered. If you require assistance, please contact our support teams by phone using your existing support numbers. We are working with the provider to restore service and will provide further updates as they become available.

Reference ID: INC0321795
Posted Sep 16, 2026 - 10:26 UTC