The incident has been resolved successfully and the impacted services are fully restored. We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner WorldPay was remediating the situation. MIM Paysafe
Reference ID: INC0301180
Posted Mar 21, 2026 - 20:09 UTC
Monitoring
Our provider WorldPay (Vantiv) implemented a solution and we are monitoring the impacted services.
MIM Paysafe
Reference ID: INC0301180
Posted Mar 21, 2026 - 20:03 UTC
Update
Please be advised that our provider WorldPay continues working on a fix with the highest priority. We appreciate your understanding while they resolve this incident. We will keep you informed on further progress. Thank you for your understanding.
Reference ID: INC0301180
Posted Mar 21, 2026 - 19:34 UTC
Update
Our provider WorldPay is actively troubleshooting this issue with the assistance from VISA. They remain engaged with the highest of priorities to resolve this situation. We will keep you informed on further progress. Thank you for your understanding. Thank you for your understanding.
MIM Paysafe
Reference ID: INC0301180
Posted Mar 21, 2026 - 16:15 UTC
Update
Please be advised that our provider WorldPay continues working on a fix with the highest priority. We appreciate your understanding while they resolve this incident. We will keep you informed on further progress.
Thank you for your understanding.
MIM Paysafe
Reference ID: INC0301180
Posted Mar 21, 2026 - 15:30 UTC
Update
Please be advised that our provider WorldPay continues working on a fix with the highest priority. We appreciate your understanding while they resolve this incident. We will keep you informed on further progress. Thank you for your understanding.
MIM Paysafe
Reference ID: INC0301180
Posted Mar 21, 2026 - 14:19 UTC
Identified
Our provider WorldPay has identified the issue and is working on a fix with the highest priority. We will keep you informed on further progress.
Thank you for your understanding.
MIM Paysafe
Reference ID: INC0301180
Posted Mar 21, 2026 - 13:10 UTC
Update
Our provider WorldPay is still investigating this matter with the highest priority and we will keep you informed on further progress.
Thank you for your understanding.
MIM Paysafe
Reference ID: INC0301180
Posted Mar 21, 2026 - 11:52 UTC
Investigating
Please note that our partner WorldPay (Vantiv) is experiencing an issue with their services, leading to an increase of declines on VISA OCT transactions, with the response message indicating "Your request has been declined by the issuing bank due to problems with the credit card account.". They are actively investigating and looking for a fix with the highest priority. We apologize for the impact this might have on your business. Further updates will follow.
MIM Paysafe
Reference ID: INC0301180
Posted Mar 21, 2026 - 10:51 UTC
This incident affected: Third Parties (Worldpay Vantiv).