Fiserv (Omaha) Funding delays

Incident Report for Paysafe

Identified

Please be advised the cause of the incident was identified.
We are in the process of implementing a solution with the highest priority.
We apologize for the impact this may have on your business.
More updates will follow.

MIM Paysafe

Reference ID: INC0299487
Posted Mar 10, 2026 - 09:26 UTC

Investigating

Please be advised that we are investigating an issue impacting some merchants integrated via Omaha (Fiserv) that's causing potential funding delays. We apologize for the impact this may have on your business. More updates will follow.
Posted Mar 09, 2026 - 18:10 UTC
This incident affects: Direct Marketing (Fiserv (Omaha) Funding).