RS2 Service Disruption
Incident Report for Paysafe
Update
Please be advised that Paysafe has noticed an issue where some fees charged to the merchant accounts in November and December are missing from the monthly statements/invoices. Our processor is currently working on identifying the cause of the missing fees and Paysafe will remove any incorrect invoices already loaded to the Business portal - RESOLVED

We are additionally working with our Vendor on remediating the following issues in Business portal:
- Rolling reserve corrections on Nov 20th and 21st, 2024 are not visible in the Business portal - IN PROGRESS
- Merchants may observe duplicate Payment fees in the Business portal - IN PROGRESS
Posted Feb 05, 2025 - 10:25 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2025 - 10:24 UTC
Update
Please be advised that Paysafe has noticed an issue where some fees charged to the merchant accounts in November and December are missing from the monthly statements/invoices. Our processor is currently working on identifying the cause of the missing fees and Paysafe will remove any incorrect invoices already loaded to the Business portal - RESOLVED
Posted Feb 05, 2025 - 09:25 UTC
Investigating
Please be advised that Paysafe has noticed an issue where some fees charged to the merchant accounts in November and December are missing from the monthly statements/invoices. Our processor is currently working on identifying the cause of the missing fees and Paysafe will remove any incorrect invoices already loaded to the Business portal.
Posted Jan 24, 2025 - 15:54 UTC
This incident affects: Third Parties (Paysafe Acquiring RS2 - Invoices).