Service Disruption - SafetyPay via paysafecard

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while Microsoft was remediating the situation.
MIM Paysafe

Reference ID: INC0284503
Posted Oct 29, 2025 - 21:00 UTC

Monitoring

Microsoft has identified and applied a fix for the issue. Due to the complexity of the solution, the complete restoration of affected services will require a certain period of time. Our teams continue to actively monitor the situation and remain vigilant for any indications of recovery.

Reference ID: INC0284503
Posted Oct 29, 2025 - 20:34 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 17:30 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 17:28 UTC

Identified

We are investigating issues with our SafetyPay service and apologize for the impact this might have on your business.
Our technical teams are working on a solution and will keep you informed on progress.
Please note this issue is due to a global Azure outage, which has been acknowledged by Microsoft.
We are monitoring the situation closely and will provide updates as they become available.
Reference ID: INC0284503
Posted Oct 29, 2025 - 17:26 UTC

Investigating

We are investigating issues with our SafetyPay service and apologize for the impact this might have on your business.
Our technical teams are working on a solution and will keep you informed on progress.

If you have any questions, please don't hesitate to contact us at techsupport@paysafecard.com
MIM Paysafe

Reference ID:INC0284503
Posted Oct 29, 2025 - 17:10 UTC
This incident affected: SafetyPay (Express Application).