Service Disruption - Optic Portal

Incident Report for Paysafe

Resolved

Please be advised the issues affecting the OPTIC Portal have been resolved.
A fix was implemented and the environment was closely monitored to confirm service stability.
During the incident, some transactions may have appeared with a delay.
Normal performance has now been fully restored.
We apologize for the inconvenience caused.
Thank you for your patience.

Reference ID: INC0281715
Posted Oct 07, 2025 - 18:46 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 07, 2025 - 13:01 UTC

Monitoring

Please be advised that we experienced a degradation with our OPTIC Portal.

The transactions may appear with a delay.

We have implemented a fix and we are monitoring the environment.

The issue is expected to be fully resolved by the end of the day.

We are sorry for the inconvenience.

MIM Paysafe

Reference ID: INC0281715
Posted Oct 07, 2025 - 12:49 UTC
This incident affected: Merchant Portals (OPTIC Portal).