The incident has been resolved successfully and the impacted services are fully restored. We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner Akamai was remediating the situation. MIM Paysafe
Reference ID: INC0295719
Posted Feb 04, 2026 - 16:40 UTC
Update
We are continuing to investigate this issue.
Posted Feb 04, 2026 - 16:32 UTC
Update
Please be advised we are investigating an incident affecting multiple Payment Processing APIs. The issue is impacting around 10 percent of all traffic towards Payment APIs, including 3DS, Card Payments and Checkout. Preliminary investigation point to be external on our vendor- Akamai side. We are contacting the vendor and investigating with the highest priority. Preliminary impact suggest that around 11% of all requests are failing with a 504 HTTP response.
Reference ID:INC0295719
Posted Feb 04, 2026 - 16:32 UTC
Update
We are continuing to investigate this issue.
Posted Feb 04, 2026 - 16:22 UTC
Investigating
We are investigating (a) potential issue(s) with the service(s) mentioned below and apologize for the impact this might have on your business. Further updates will follow.
MIM Paysafe
Reference ID:INC0295719
Posted Feb 04, 2026 - 16:21 UTC
This incident affected: Processing and APIs (Card payments API, Direct Debit API).