Service Disruption - Account Statement Reports

Incident Report for Paysafe

Monitoring

A solution has been implemented and activity on the impacted services is being monitored.
We will keep you informed on progress.

MIM Paysafe

Reference ID: INC0282791
Posted Oct 16, 2025 - 12:59 UTC

Investigating

We are investigating a potential issue with the service mentioned below and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0282791
Posted Oct 16, 2025 - 08:07 UTC
This incident affects: Third Parties (Paysafe Acquiring RS2 - Financial Reporting).