PXP Webhost API Service Disruption

Incident Report for Paysafe

Resolved

This incident has been resolved.
Posted 15 days ago. Mar 20, 2025 - 01:34 UTC

Investigating

We are investigating a potential issue with our PXP Webhost API and apologize for the impact this might have on your business.

Further updates will follow.

SRO Paysafe
Posted 15 days ago. Mar 20, 2025 - 01:17 UTC
This incident affected: Direct Marketing (PXP Webhost API).