Please be advised of the updates on the below issues: - Rolling reserve corrections on Nov 20th and 21st, 2024 not visible in the Business portal, Reference ID: INC0253480 has been RESOLVED. All corrections should be available in the portal. - Merchants may observe duplicate Payment fees in the Business portal - Reference ID: INC0251870 - A fix is being tested. It is expected to be deployed on May 16th. We will update once the fix is deployed and issue resolved.
We apologize for the impact these issues have on your business. We value your partnership and appreciate your understanding while our partner is remediating the situation.
Posted May 14, 2025 - 10:41 UTC
Investigating
Please be advised that Paysafe continues to work alongside vendor on remediating the below reported incidents in the Business portal. The root cause for both outstanding issues has been identified. The fixes will be deployed as soon as possible. - Rolling reserve corrections on Nov 20th and 21st, 2024 are not visible in the Business portal - IDENTIFIED / Reference ID: INC0253480 - Merchants may observe duplicate Payment fees in the Business portal - IDENTIFIED / Reference ID: INC0251870
MIM Paysafe
Posted Mar 18, 2025 - 11:39 UTC
This incident affects: Third Parties (Paysafe Acquiring RS2 - Invoices).