The incident has been resolved successfully and the impacted services are fully restored. We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner Peoples Trust was remediating the situation. MIM Paysafe
Reference ID:INC0302811
Posted Apr 06, 2026 - 02:02 UTC
Monitoring
Our provider Peoples Trust implemented a solution and we are monitoring the impacted services.
MIM Paysafe
Reference ID:INC0302811
Posted Apr 06, 2026 - 01:05 UTC
Update
People's Trust continues to work on a fix for the incident. We apologize for the impact this might have on your business. Further updates will follow. MIM Paysafe
Reference ID:INC0302811
Posted Apr 05, 2026 - 19:41 UTC
Update
Our provider - Peoples Trust continue to work on implementing a fix and service restoration. We apologize for the impact this might have on your business. Further updates will follow. MIM Paysafe
Reference ID:INC0302811
Posted Apr 05, 2026 - 16:38 UTC
Identified
Our provider Peoples Trust (Interac) has identified the root cause and is working on implementing a solution. MIM Paysafe
Reference ID: INC0302811
Posted Apr 05, 2026 - 13:46 UTC
Update
Our provider Peoples Trust are still investigating, we will keep you informed on further progress. MIM Paysafe
Reference ID:INC0302811
Posted Apr 05, 2026 - 13:07 UTC
Investigating
Our partner Peoples Trust is investigating a potential issue with their e-Transfer services. We apologize for the impact this might have on your business. Further updates will follow.
MIM Paysafe
Reference ID:INC0302811
Posted Apr 05, 2026 - 12:37 UTC
This incident affected: Third Parties (Interac e-Transfer).