Paysafe Acquiring RS2 - Batch Processing-Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the affected funds have been sent as late as 20th of April.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner was remediating the situation.
MIM Paysafe

Reference ID: INC0257941
Posted Apr 24, 2025 - 12:31 UTC

Monitoring

Our provider has implemented a solution and we are monitoring the impacted services.

MIM Paysafe

Reference ID:INC0257941
Posted Apr 23, 2025 - 07:50 UTC

Update

Please be advised that if your funds have not been received today, it appears your account was regrettably affected by the batching delay. Due to bank closures for Easter, your funds will be posted on the next business day, Tuesday April 22.
Thank you for your understanding.
Posted Apr 18, 2025 - 08:02 UTC

Update

We are continuing to investigate this issue.
Posted Apr 17, 2025 - 11:11 UTC

Investigating

Dear All, 

Please be advised that we are investigating an issue that may cause delays with the batching for EU Acquiring RS2. 

Kind Regards,

Reference ID:INC0257941
Posted Apr 17, 2025 - 11:10 UTC
This incident affected: Third Parties (Paysafe Acquiring RS2 - Batch Processing).