Service Disruption - Cardinal

Incident Report for Paysafe

Resolved

This incident has been resolved.

MIM Paysafe

Reference ID:INC0276914
Posted Aug 27, 2025 - 18:28 UTC

Monitoring

Our partner Cardinal is investigating a potential issue with their services. We apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID:INC0276914
Posted Aug 27, 2025 - 17:28 UTC
This incident affected: Third Parties (Cardinal Commerce (3DS2)).