Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. Please note that the errors were restricted to VISA transactions. We value your partnership and appreciate your understanding while our partner Interchecks was remediating the situation.
MIM Paysafe

Reference ID:INC0258006
Posted Apr 17, 2025 - 23:15 UTC

Investigating

We are investigating a issue with the service mentioned below and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID:INC0258006
Posted Apr 17, 2025 - 22:32 UTC
This incident affected: Third Parties (Interchecks).