Multibanco Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner SIBS (Multibanco) was remediating the situation.
MIM Paysafe

Reference ID: INC0256894
Posted Apr 03, 2025 - 20:55 UTC

Investigating

We are investigating а potential issue with our provider SIBS (Multibanco) and apologize for the impact this might have on your business.

Further updates will follow.

MIM Paysafe
Posted Apr 03, 2025 - 20:30 UTC
This incident affected: Third Parties (Multibanco).