Service Disruption - Merchant payments and Reporting

Incident Report for Paysafe

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 11:29 UTC

Investigating

Please be advised that due to a technical issue, the daily merchant reporting and payment scheduled processes could not be completed within expected timeframe.
As a result, Merchant posting and payments scheduled for August 10th will experience a 1-day delay and will be processed on August 11th.
The root cause of the incident was identified, and we are applying additional preventive measures.
We apologize for the impact this might have on your business

MIM Paysafe

Reference ID: INC0316965
Posted Aug 10, 2026 - 16:36 UTC
This incident affected: Processing and APIs (Batch Upload, Merchant Payments).