Service Disruption
Incident Report for Paysafe
Resolved
The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe
Posted Jul 17, 2024 - 21:02 UTC
Update
We are continuing to investigate this issue.
Posted Jul 17, 2024 - 15:48 UTC
Update
We are continuing to investigate this issue.
Posted Jul 17, 2024 - 15:34 UTC
Investigating
We are investigating a potential issue with TSYS and we expect a batch delay in funding our merchants. We apologize for the inconvenience caused

Further updates will follow.

MIM Paysafe
Posted Jul 17, 2024 - 15:32 UTC
This incident affected: Direct Marketing (TSYS USPP Funding).