Service Disruption - Moneris

Incident Report for Paysafe

Resolved

Dear All,

Please be advised that the incident was caused by an issue on a single bank's side.
It affected only VISA cards issued by the said bank with specific BINs.
The incident has been confirmed as resolved by VISA support team, and processing rates have fully recovered to regular levels.
We can observe steady rate of 3009 errors matching historical data.
Please note INC0276026 is now resolved.
Best Regards,

Reference ID:INC0276026
Posted Aug 21, 2025 - 07:46 UTC

Investigating

We are investigating a potential issue with the services mentioned below and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID:INC0276026
Posted Aug 21, 2025 - 03:48 UTC
This incident affected: Third Parties (Moneris).