The incident has been resolved successfully and the impacted services are fully restored. We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while the situation was being remediated.
MIM Paysafe
Reference ID:INC0298932
Posted Mar 03, 2026 - 04:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 03, 2026 - 03:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 03:39 UTC
Investigating
Please be advised that our QR code partner is currently experiencing service degradation. We have successfully applied mitigation measures and rerouted the traffic to our alternate solution. Our teams remain actively engaged and are closely monitoring the situation. We apologize for the impact this might have on your business. Further updates will follow.