Service Disruption - Paypal
Incident Report for Paysafe
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 05:20 UTC
Investigating
Please be advised that we experienced an intermittent degradation with our partner Paypal.
The incident has been resolved successfully and the impacted services are fully restored.
We apologize for the impact this issue had on your business. We value your partnership and appreciate your understanding while our partner Paypal was remediating the situation.
MIM Paysafe
Posted Nov 06, 2024 - 05:20 UTC
This incident affected: Third Parties (PayPal).