TSYS Acquiring solutions Service Disruption

Incident Report for Paysafe

Resolved

The incident has been resolved successfully and the impacted service is fully restored.
We apologize for the impact this issue had on your business.
We value your partnership and appreciate your understanding while the situation was being remediated.

MIM Paysafe

Reference ID: INC0256022
Posted Mar 24, 2025 - 16:36 UTC

Monitoring

A solution has been implemented and activity on the impacted services is being monitored.
We will keep you informed on progress.

MIM Paysafe

Reference ID: INC0256022
Posted Mar 24, 2025 - 16:27 UTC

Investigating

We are investigating a potential issue with TSYS Acquiring solutions and apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID: INC0256022
Posted Mar 24, 2025 - 16:16 UTC
This incident affected: Third Parties (TSYS Acquiring solutions).