Service Disruption - SafetyPay Payouts

Incident Report for Paysafe

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 21:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2026 - 20:39 UTC

Investigating

Due to a third-party disruption, our Payout services are currently experiencing limited impact. We are closely monitoring the situation.
We apologize for any inconvenience this may cause to your business. Further updates will follow.

Reference ID: INC0318031
Posted Aug 18, 2026 - 19:22 UTC
This incident affected: SafetyPay (Payouts).