Service Disruption - Skrill API/MQI

Incident Report for Paysafe

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 17:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2026 - 16:45 UTC

Investigating

We are investigating potential issue with the Skrill Status Notifications Service.
Some merchants or partners may incorrectly receive emails regarding failed Skrill API/MQI login attempts.
We apologize for the impact this might have on your business.
Further updates will follow.

MIM Paysafe

Reference ID:INC0318981
Posted Aug 26, 2026 - 15:19 UTC
This incident affected: Skrill (Skrill API).