Please note that the previously reported issues are applicable to the July 2026 invoices. June 2026 invoices for multi-currency accounts have been corrected and are now available in the Optic portal. We continue to work on resolving the discrepancies with the highest priority. We are working alongside partner support teams with the highest priority to provide corrected invoices. We apologize for the impact this may have on your business. Further updates will follow.
Reference ID: INC0316150
Posted Aug 03, 2026 - 13:30 UTC
Investigating
Please be advised that following additional review and validation we have identified further discrepancies in the Monthly statements (invoices) for June 2026 for multi-currency accounts, currently available in the Optic Portal, previously reported in INC0314578. https://status.paysafe.com/incidents/ykcw07rjvmxn Our teams have escalated the incident to partner. We are working alongside partner support teams with the highest priority to resolve the issue. We apologize for the impact this may have on your business. Further updates will follow.
Reference ID: INC0314578
Posted Aug 03, 2026 - 08:32 UTC
This incident affects: Merchant Portals (OPTIC Portal) and Third Parties (Paysafe Acquiring RS2 - Batch Processing, Paysafe Acquiring RS2 - Invoices, Paysafe Acquiring RS2 - Financial Reporting).